1 (edited by archimage 2017-08-28 21:15:37)

Topic: Retroarch configuration


I have 2 computers on Windows 10 both with the same CRT PVM 20L4.

On has ArcadeVGA 5000 and the second one has ATI Radeon 4890 with latest CRT Emudrivers beta 2.

The first one works well with Retroarch.

I simply use a launcher with a config file for each core, and resolution change utility.

Each system is set with it's native resolution.

For example, megadrive is 320 x 240, I set a custom viewport in a cfg file, and load a .bat file containing the resolution change to 320x240 and the game loads pixel perfect.

I set integer scale yes, vsync on, bilinear filtering off...

No windowed fullscreen.

With the CRT emudrivers with the same settings the viewport is very small.

It seems like it doesn't recognize the 320x240 resolution as the one with the ArcadeVGA...

I have tried many things, and looked around in the forums and I found nothing on how to play Retroarch with CRT Emudrivers, everything is focused on Groovymame, and many people claim that it's Retroarch who don't want to get involved in CRT.

But actually Retroarch works well on CRT on my Raspberry pi and with ArcadeVGA, so what's missing here ?

Best regards


Re: Retroarch configuration

Have you actually installed any resolutions, specifically 320x240? Does Arcade OSD show it in its list?


Re: Retroarch configuration

Yes I used user modes, then tried super resolutions, then both at the same time, it shows on the osd, works under groovymame, the desktop show in 320x240, but for some reason Retroarch don't show properly, it looks small, dark and blurry.

The same goes for Super Famicom 256x224.

With ArcadeVGA I don't have 224 modes, so I make it work with 240.


Re: Retroarch configuration

Take a look at this thread:

http://forum.arcadecontrols.com/index.p … msg1586903


Re: Retroarch configuration

Hello Recap, thank you, I tried to switch to D3D with same settings, but it crashes when it's combined with windows fullscreen false.


Re: Retroarch configuration

Sorry but there's a mistake in the first post, it's Windows 10 and not Windows 7

7 (edited by archimage 2017-08-29 00:51:31)

Re: Retroarch configuration

it seems like there's a problem with compatibility between opengl/d3d in Retroarch and the drivers... Actually in my other machine equipped with Arcade VGA gl works just perfect, not in this one with the Radeon 4890. When I switch to d3d like it was mentionned in the thread I can't prevent crashes when windowd fullscreen is disabled, when enabled it's just the same small and blurry image


Re: Retroarch configuration

Can't talk about recent versions, but I've tested RA the past year with an HD-4670 under W7 and both, D3D and GL, and no crashes here. I'd suggest you to focus on the latter since you can expect better input lag figures with it. And windowed fullscreen should be set to false. First off, do you manage to display RGUI at H x 240 without crashes (right after setting the desktop to that res.)?

(I'm moving this thread to the Discussion subforum, by the way.)

9 (edited by archimage 2017-08-29 11:28:56)

Re: Retroarch configuration

Yes I have managed to turn switch desktop to 320x240, then RGUI on, D3D also, but it's still small and blurry, when I set windowed fullscreen to false it crashes after restart. RA I am using is the latest update.


Re: Retroarch configuration

That's weird, unless your .CFG file has something wrong. If you try a version from 08.2016 with a properly set .CFG and it still happens, I can only suggest asking in their official forums, since there are people there using 15 kHz.


Re: Retroarch configuration

It works with 1.3.6 indeed. So there's obviously a problem between latest versions and the drivers in with D3D.


Re: Retroarch configuration

Finally it works when I don't edit the config file manually, when I choose everything from the gui no problem with latest version