1 (edited by cubelindo 2017-04-07 02:53:54)

Topic: Integrated GPU HD8570D in AMD A8-6600K

Hi, this is my first post here, my name is Cubelindo from Spain, and I'm building a PC for a Naomi cabinet with a Sony Trinitron 29" TV as a monitor (PAL)

The PC I have available has no discrete graphic card. It runs on an A8-6600K processor, which has an integrated HD 8570D card

First of all, I'm not very sure if this integrated card is supported. It looks like newer APUs are supported indeed (R5 and R7) but for this APU the closest I can find in the supported list in the download thread is "AMD Radeon™ HD 8180 - HD 8400 Series Graphics" which I guess does not  include HD8570D, so if somebody could confirm if I am right I would very much appreciate.

I have not been able to find examples of using an integrated GPU to drive a TV, the mainstream seems to be using discrete cards. I wonder if an error flashing an APU could possibly make the processor side of the APU malfunction. Again, if somebody could give me hint it would be great.

I find this setup interesting because the HD8570D seems to be a better graphic card than the HD5450 (the most used HD5000 series for CRTs, as far as I can tell) so It would not make much sense to use an HD5450 in my PC (I would have to go to an HD5750 to have better specs than the HD8570D)

Thanks!

EDIT: well, I thought I had read it carefully, but the non GCN drivers have as compatible " APU: AMD Radeon™ HD 6000D, HD 7000D, HD 8000D, HD 6000G, HD 7000G, HD 8000G Series" so I guess HD8570D is included. I'll post my results if I try.

Re: Integrated GPU HD8570D in AMD A8-6600K

Thanks cubelindo,

I'm really interested in seeing how the installation goes on an APU. To be honest I expected more people would have tried this already, happy to see finally someone exploring this possibility.

With regards to flashing your APU, I believe it's not possible to use ATOM-15-modified bios for this. I'd say the VBIOS is not separate as it is in discrete GPUs.

Re: Integrated GPU HD8570D in AMD A8-6600K

Calamity, how do you think I should proceed? This is my first flash

Re: Integrated GPU HD8570D in AMD A8-6600K

No, I meant you shouldn't flash at all!

Just install CRT Emudriver.

Re: Integrated GPU HD8570D in AMD A8-6600K

Sorry for the long wait

I had to dissassemble a Naomi, repair it and re-assemble again.

So, I have intalled "CRT Emudriver & CRT Tools 2.0 beta 10 (Crimson 16.2.1 non-GCN* cards) for Windows 7/8/10 64-bits". I'm running Windows 8.1
I had the AMD Catalyst application and read it could cause some trouble, so I disintalled it and reintalled the CRT Emudriver

My screen is a Sony Trinitron PAL TV, with a VGS to SCART cable from a trusted cable maker (retrocables)

As long as I can see, nothing happened. I run Setup and get the installed message, and I run vmmaker and get a cmd screen where I see my two screens are detected and a ready prompt. HD8570D is detected also.

The instructions say something about a vmmaker ini file, but I have none. Hyperspin is installed in the computer, with a regular MAME distribution.

If I try to change my second screen resolution (the TV), I can only go al low as 640x480. I get no signal in the TV

Arcade-osd only show resolutions down to 640x480

And there am I, stuck  :(

6 (edited by cubelindo 2017-07-24 21:26:49)

Re: Integrated GPU HD8570D in AMD A8-6600K

Well, some new data

I made a fresh Win10 install + the drivers of the HD8570D (not the Catalyst suite)

I also found the "generate modelines" button and the "install modelines" button, something I overlooked the previous time

I had no success, this is the output of vmmaker, setting PAL Tv as my monitor:

24 modelines generated.

"240x192_50 15.60KHz 50.00Hz" 4.74 240 248 272 304 192 243 245 312 -hsync -vsync
"240x200_50 15.60KHz 50.00Hz" 4.74 240 248 272 304 200 247 249 312 -hsync -vsync
"248x192_50 15.60KHz 50.00Hz" 4.87 248 256 280 312 192 243 245 312 -hsync -vsync
"256x192_50 15.60KHz 50.00Hz" 4.99 256 264 288 320 192 243 245 312 -hsync -vsync
"256x224_50 15.60KHz 50.00Hz" 4.99 256 264 288 320 224 259 261 312 -hsync -vsync
"256x239_50 15.60KHz 50.00Hz" 4.99 256 264 288 320 239 267 269 312 -hsync -vsync
"256x240_50 15.60KHz 50.00Hz" 4.99 256 264 288 320 240 267 269 312 -hsync -vsync
"256x244_50 15.60KHz 50.00Hz" 4.99 256 264 288 320 244 269 271 312 -hsync -vsync
"256x256_50 15.60KHz 50.00Hz" 4.99 256 264 288 320 256 275 277 312 -hsync -vsync
"320x224_50 15.60KHz 50.00Hz" 6.36 320 336 368 408 224 259 261 312 -hsync -vsync
"320x240_50 15.60KHz 50.00Hz" 6.36 320 336 368 408 240 267 269 312 -hsync -vsync
"320x244_50 15.60KHz 50.00Hz" 6.36 320 336 368 408 244 269 271 312 -hsync -vsync
"320x256_50 15.60KHz 50.00Hz" 6.36 320 336 368 408 256 275 277 312 -hsync -vsync
"336x224_50 15.60KHz 50.00Hz" 6.61 336 352 384 424 224 259 261 312 -hsync -vsync
"384x240_50 15.60KHz 50.00Hz" 7.36 384 400 432 472 240 267 269 312 -hsync -vsync
"512x448_50 15.62KHz 50.00Hz" 9.88 512 528 576 632 448 518 523 625 interlace -hsync -vsync
"512x478_50 15.62KHz 50.00Hz" 9.88 512 528 576 632 478 533 538 625 interlace -hsync -vsync
"512x480_50 15.62KHz 50.00Hz" 9.88 512 528 576 632 480 534 539 625 interlace -hsync -vsync
"512x512_50 15.62KHz 50.00Hz" 9.88 512 528 576 632 512 550 555 625 interlace -hsync -vsync
"544x242_50 15.60KHz 50.00Hz" 10.48 544 560 608 672 242 268 270 312 -hsync -vsync
"640x200_50 15.60KHz 50.00Hz" 12.36 640 664 720 792 200 247 249 312 -hsync -vsync
"640x480_50 15.62KHz 50.00Hz" 12.38 640 664 720 792 480 534 539 625 interlace -hsync -vsync
"768x512_50 15.62KHz 50.00Hz" 14.88 768 792 864 952 512 550 555 625 interlace -hsync -vsync
"768x576_50 15.62KHz 50.00Hz" 14.88 768 792 864 952 576 582 587 625 interlace -hsync -vsync

>>modelist install               
Installing modelines in system...
Mode "240x192_50 15.60KHz 50.00Hz" rejected by driver.
Mode "240x200_50 15.60KHz 50.00Hz" rejected by driver.
Mode "248x192_50 15.60KHz 50.00Hz" rejected by driver.
Mode "256x192_50 15.60KHz 50.00Hz" rejected by driver.
Mode "256x224_50 15.60KHz 50.00Hz" rejected by driver.
Mode "256x239_50 15.60KHz 50.00Hz" rejected by driver.
Mode "256x240_50 15.60KHz 50.00Hz" rejected by driver.
Mode "256x244_50 15.60KHz 50.00Hz" rejected by driver.
Mode "256x256_50 15.60KHz 50.00Hz" rejected by driver.
Mode "320x224_50 15.60KHz 50.00Hz" rejected by driver.
Mode "320x240_50 15.60KHz 50.00Hz" rejected by driver.
Mode "320x244_50 15.60KHz 50.00Hz" rejected by driver.
Mode "320x256_50 15.60KHz 50.00Hz" rejected by driver.
Mode "336x224_50 15.60KHz 50.00Hz" rejected by driver.
Mode "384x240_50 15.60KHz 50.00Hz" rejected by driver.
Mode "512x448_50 15.62KHz 50.00Hz" rejected by driver.
Mode "512x478_50 15.62KHz 50.00Hz" rejected by driver.
Mode "512x480_50 15.62KHz 50.00Hz" rejected by driver.
Mode "512x512_50 15.62KHz 50.00Hz" rejected by driver.
Mode "544x242_50 15.60KHz 50.00Hz" rejected by driver.
Mode "640x200_50 15.60KHz 50.00Hz" rejected by driver.
Mode "640x480_50 15.62KHz 50.00Hz" rejected by driver.
Mode "768x512_50 15.62KHz 50.00Hz" rejected by driver.
Mode "768x576_50 15.62KHz 50.00Hz" rejected by driver.
24 modelines installed.

Looks like I need another video card, right?