1 (edited by moloo2 2019-05-06 13:42:50)

Topic: problem with Attract Mode front-end

My configuration is Windows 10, Radeon HD5450, CRT Emudriver 2.0 - beta 15 + RGB SCART TV runs at 15kHz. Desktop res is 480i (60Hz).
All graphic modes when testing on Arcade OSD are displayed correctly. Unfortunately, I have a problem with Attract Mode 2.5.1 front end (I have not tested previous versions). When I start AM in fullscreen mode the image is displayed incorrectly, as in the picture below, it looks like 480p (I do not see interlace). Does anyone have any idea how to run Attract in fulscreen mode in the desktop resolution - 480i or any other res from Emudriver modelist?

https://lh3.googleusercontent.com/HG8jWwJ50H2gXjLXU1QUPkHifJXQETZeX0iaSczK8W-uB8ub4KPFlSUNYE9zESb7BBTTYY4OXmF3ucUmiRVuOd3J7dWdQPi8QMkjOQelLsa2pOIpH8ytH4su5zIyBbD1b_ID4TQPlFheissyiL0rWlS5_EVI1XKIbcLQgLjzbJvPkw_frpS2XV8rnFJFTZcHkmwrvinHQX69ZM_5i30B26EDdqyzI8zWlPRIIVMQV103j-kwV-oLO5CILMdBmZDWYKKKLQHOgfV8lDj0HHgK0E7Q5jbff6sSgUriHOT5Y4QTuLTIXMxuLpAfHkMZKiq5-NMgwb0On1MExO659k1gyeCzW49c8KFkTyYtwEwYHpLjFTuomcAvVx5A5Lj3YqMHv-3zWJck-nVJA_JP5md0LahmovfiK4kcs2zq7TS71gkQ3DA8c93YL0BuANB0Bl8cZEI5XukjXNNRIfv3TMV-o4KvWbHKkVactXB8XWgiOhtX-VQXnjp-RExAS2lAk3JkHD1gsMDh7Ac4j5EAbik9ZtFvv99xIgF-g3Cbzv90_-TUExWzanXts6NbuIBxZanHzFSuIsDUAQBrQocmgOQRBbwQ2hoV6uWcupOlqpY7Qcg5SSXAzkvjuicPePewzQ1bmad2ypSfuj71JUbCiZss70c7m516HBmlr5lVFn6U8jMrG8FqrwxEThXnBotmphQP0ESRNHOXYAewOrFxQhwf4YTP=w649-h864-no

Re: problem with Attract Mode front-end

Hi moloo2,

The problem with Attract-Mode, like many other software these days, is that internally it doesn't hold a refresh value for screen configuration. Since your desktop is set up at 640x480, and this is a standard resolution which your video card "knows" and has different refresh rates defined for it, the wrong refresh is picked instead of the right, current one (15 kHz).

Accepting the fact that the frontend author is not going to provide support for user specified refresh rates (actually it's not his fault but SFML library's he's using), a simple workaround would be setting the desktop at a resolution that's non-standard, so the video card has no other definition for it that the one we provide.

A good choice may be 648x486@60. Notice the width and heigh values are chosen to make a perfect 4:3 aspect ratio.

In order to add this mode, edit the mode list in user_modes.ini in VMMaker's folder and generate & install the modes. Then pick it as your desktop mode from either Windows display setup or Arcade OSD.